[Date Prev] [Date Next] [Prev in Thread] [Next in Thread] [Date Index] [Thread Index]

Re: SRM 7.6 Destroying ITSM 7.0.3 Email Generation?



** Okay. The below filter doesn't exist in ITSM 7.6 but in ITSM 7.0.03 it does and it does a set field action from NTE:CFG-Notification Events.

Thanks
Mahesh

On Sun, Aug 29, 2010 at 5:50 PM, Pierson, Shawn <Shawn.Pierson@sug.com> wrote:
**

I’ve verified that they exist, but I’m wondering if some records that should be in place are no longer there.  Upon further investigation, I see in Change Management a filter is being called named NTE:NPC:GetPreferences_155_NTE, which is unable to find anything, and immediately after that the record in NTE:SYS-NT Process Control is deleted.  I’m currently testing some things in that area, but I’m thinking that it’s possible that SRM deleted the data in the form that it’s referencing.

 

Thanks,

 

Shawn Pierson

Remedy Developer | Southern Union

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Mahesh
Sent: Sunday, August 29, 2010 5:36 PM
To: arslist@ARSLIST.ORG
Subject: Re: SRM 7.6 Destroying ITSM 7.0.3 Email Generation?

 

** ITSM 7.6 Notification sub-system doesn't contain the following forms.

  1. NTE:SYS-Group NT Control
  2. NTE:SYS-Individual NT Control

Make sure if these forms exist as ITSM 7.0.03 uses them.

Thanks
Mahesh

On Sun, Aug 29, 2010 at 10:40 AM, Pierson, Shawn <Shawn.Pierson@sug.com> wrote:

**

Good morning,

 

I upgraded our SRM 2.2 install to 7.6, and everything seemed to have went well until we started trying to use ITSM and noticed that it is incapable of generating emails.  The Email Engine itself works, so our custom applications that don’t use the NTE subsystem are fine, but most other emails from ITSM simply don’t get generated.

 

In my Filter log, I see (in the example of Change Management) that it gets to the filter CHG:CRQ:NotificationGenerator_899_ModifyNotificationProcessControl`! and pushes the data correctly, but after that I don’t see anything occur where it would send an email.  I do see that the Change Manager information is pulled back in NTE:NPC:GetPreferences_150_PeopleSupportStaff, but beyond that it doesn’t really do anything.

 

So basically, my Production system is dead in the water because of this.  We’re on ITSM 7.0.3 Patch 9 and Patch 7000, and this only became an issue after upgrading to SRM 7.6 Patch 1.  Unfortunately, it looks like SRM modified thousands of ITSM forms, fields, and workflow, so there is no good way to tell what could have been affected by this.  Also unfortunately, BMC support has been less than helpful, trying to tell me it’s just a performance problem, and not listening to me and for some reason thinking that it only affects Approval emails.

 

Thanks,

 

Shawn Pierson

Remedy Developer | Southern Union

Private and confidential as detailed here. If you cannot access hyperlink, please e-mail sender.

_attend WWRUG10 www.wwrug.com ARSlist: "Where the Answers Are"_

 

_attend WWRUG10 www.wwrug.com ARSlist: "Where the Answers Are"_

Private and confidential as detailed here. If you cannot access hyperlink, please e-mail sender.
_attend WWRUG10 www.wwrug.com ARSlist: "Where the Answers Are"_

_attend WWRUG10 www.wwrug.com ARSlist: "Where the Answers Are"_