[Date Prev] [Date Next] [Prev in Thread] [Next in Thread] [Date Index] [Thread Index]

Re: Question concerning Attachment Pool field



**
Hey Dave,
What version of the Dev Studio is that hot fix for?


On Mon, Jun 10, 2013 at 10:39 AM, Shellman, David <dave.shellman@te.com> wrote:
**

FYI.  I received a hotfix today that addressed the missing “Move To …” option for right mouse click on an Attachment field.

 

The hotfix address Developer Studio does not show “Move Field To…” action for attachment fields and Developer Studio does not allow custom fields to be dragged into panel fields with Defect SW00452089.

 

Have a great day.

 

Dave

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Shellman, David
Sent: Wednesday, May 29, 2013 7:54 AM


To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

Amit,

 

Thanks.  Any specific reason why the right mouse options are different for this field?

 

Dave

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Kumar, Amit (Remedy-Dev Studio R&D)
Sent: Wednesday, May 29, 2013 7:50 AM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

The “Move  to“ option was not available in the 7.6 04 and 8.0 version for attachment field.

 

Regards,

Amit Kumar

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Shellman, David
Sent: Wednesday, May 29, 2013 12:38 AM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

The right mouse “Move To” was not in the original 8.1 install.  Not sure if it was there in 7.6.04 or 8.0.  I did say the right mouse click functionality was different than the other fields.

 

The defect ID for this issue is SW00452089.

 

The hot fix I was given is a cumulative hot fix, the notes in the file said it was for defect SW00452341.

 

Dave

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Joe D'Souza
Sent: Tuesday, May 28, 2013 2:55 PM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

I would report it so they fix the hot fix too to make it work like it does for all other fields.

 

Did they say which patch, this hot-fix will be a part of?

 

Cheers

 

Joe

 


From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Shellman, David
Sent: Tuesday, May 28, 2013 1:54 PM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

I was given a  Hotfix today.  The drag and drop functionality to a tab is now working.

 

The odd thing is that when I right mouse click on an Attachment field I still don’t see “Move To” option.  Not sure I need it now that drag and drop is working again.  It’s just odd that the right mouse menu is different for this field type than other field types.

 

Dave

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Shellman, David
Sent: Tuesday, May 21, 2013 10:46 AM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

Hmmm.  I just spoke with support and it seems the hot fix is not available yet.  They need to expedite for Dev Studio 8.1.

 

Dave

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Kumar, Amit (Remedy-Dev Studio R&D)
Sent: Tuesday, May 21, 2013 7:34 AM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

This defect has been addressed. Please contact BMC support with defect ID SW00452089 to get hot fix.

 

Regards,

Amit Kumar

 

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of laurent matheo
Sent: Tuesday, May 21, 2013 7:41 AM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

Guilty as charged I guess :)
I didn't see that one... I saw a couple of issues in dev studio but not this one.


On 21 May, 2013,at 02:43 AM, Joe D'Souza <jdsouza@SHYLE.NET> wrote:

Thanks Dave for the update.. this is a good to know for those of us not already there.

 

How does something basic like this not get caught before a product release? You would think it would have got caught at least during the beta release program. I admit I signed on to that 7.7 program but didn’t have the minimum hardware or time to actually install or test anything. With the resources that these servers need these days, you need more than a personal laptop that has barely 4 GB RAM and a TB or less of hard drive space and mines only 500 GB.

 

Joe

 


From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Shellman, David
Sent: Monday, May 20, 2013 11:31 AM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

The defect has been entered. 

 

In this case we’re attempting to reduce space on a form.  It’s probably something that doesn’t come up often.  I’ve brute forced my way around it for now. 

 

Now on to other things that are broken and not working.  Mostly because we’re making form and workflow changes.

 

Dave

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Jason Miller
Sent: Monday, May 20, 2013 11:26 AM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

Are they going to give you a hotfix?

On May 20, 2013 7:51 AM, "Shellman, David" <dave.shellman@te.com> wrote:

**

Support has confirmed that drag and drop is broken with Attachment fields to a Tab field using 8.1 Dev Studio in Best Practice mode.  Actually it looks like drag and drop to a Tab field is broken for all fields in Best Practice mode in 8.x Dev Studio.  Fortunately, right mouse click and “”Move To” is available for most field types.

 

Dave

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Jason Miller
Sent: Thursday, May 16, 2013 1:24 AM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

Affirmative.  Looks like my advice to use DS 8.1 has steered you wrong.

 

It works as expected with DS 7.6.04 but does not with 8.1.  I too get the red X with 8.0/8.1 unless I convert to Base, overlay the form and the view.

 

On Wed, May 15, 2013 at 6:19 PM, Shellman, David <dave.shellman@te.com> wrote:

**

Jason,

 

In your Scenario 3, you were able to drag and drop the attachment field to a tab on the panel field with Dev Studio 7.6.04 in Best Practice Mode?

 

With the 8.1 Dev Studio, I go to drag and when the field is over the tab it displays a red X.

 

Thanks for testing the different scenarios.

 

I had a brief exchange with support.  I'll go into more detail when I speak to them tomorrow.

 

Dave


On May 15, 2013, at 6:31 PM, "Jason Miller" <jason.milja2@GMAIL.COM> wrote:

**

Ran some tests...  I verified this is an issue with forms created as Custom in Best Practice mode and Dev Studio 8.0 and 8.1.  I think it has something to do with not being able to overlay the view of a Custom form.

 

Scenario 1

AR System 7.6.04 SP4

  1. Created Regular form in Base mode with DS 7.6.04 SP4
  2. Created tabbed Panel Holder (PH) with two panels
  3. Created Attachment Pool (AP) with one Attachment Field (AF) outside of the PH
  4. Dragged AP to first panel (p1) on PH
  5. Dragged AP to second panel (p2) on PH
  6. Switched to DS 8.0 in Best Practice mode
  7. Created Form and View overlay
  8. Dragged AP off of p2
  9. Dragged AP to p1
  10. Wanted to try Move Field To but is not option with AP
  11. Switched to DS 7.6.04 in Base mode
  12. Move Field To is still not an option

When I started this scenario I thought this machine was 8.1 but didn't very until the end.  Scenario 2 is with 8.1 to since that is the 8.x version in question.

 

 

Scenario 2

AR System 7.6.04 SP4

  1. Using 7.6.04 SP4 deleted overly from scenario 1 returning form to state after steps 1 - 5
  2. Switched to DS 8.1 in Best Practice mode
  3. Created Form and View overlay
  4. Dragged AP off of p2
  5. Dragged AP to p1
  6. Wanted to try Move Field To but is not option with AP
  7. Switched to DS 7.6.04 in Base mode
  8. Move Field To is still not an option

 

Scenario 3

AR System 7.6.04 SP4

  1. Created Regular form in Best Practice mode with DS 7.6.04 SP4
  2. Created tabbed Panel Holder (PH) with two panels
  3. Created Attachment Pool (AP) with one Attachment Field (AF) outside of the PH
  4. Dragged AP to first panel (p1) on PH
  5. Dragged AP to second panel (p2) on PH
  6. Switched to DS 8.1 in Best Practice mode
  7. Cannot drag AP off p2
  8. Duplicate View
  9. Remove AP and AF from original default view
  10. Add AP and AF back to original default view, field goes back to p2
  11. Switched to DS 8.0 in Best Practice mode
  12. Cannot drag AP off p2
  13. Switched to DS 8.1 in Best Practice mode
  14. Converted form to Base
  15. Cannot drag AP off p2
  16. Converted form to Custom
  17. Cannot drag AP off p2
  18. Switch to Best Practice mode with DS 7.6.04 SP4
  19. Dragged AP from p2
  20. Switched to DS 8.1 in Best Practice mode
  21. Converted form to Base
  22. Created Overlay
  23. Cannot drag AP to p2
  24. Created View Overlay
  25. Can drag AP to p2

 

 

On Wed, May 15, 2013 at 1:20 PM, Jason Miller <jason.milja2@gmail.com> wrote:

I would like for you to take that out of the equation too :)

 

Have you tried removing the field from the view and adding it back?  I am wondering if that will give you the ability to place it elsewhere before saving it in the view.

 

I just thought about it.  We have Dev Studio 7.6.04 on the app our 7.6.04 servers so I can try it out.

 

Jason

 

On Wed, May 15, 2013 at 11:41 AM, Shellman, David <dave.shellman@te.com> wrote:

**

When something doesn’t work right on a complicated form I create simple forms so I can take some of the complexity out of the equation.

 

If you’re on 7.6.04 (server and dev studio) give it a quick test.  That would at least take the question of 8.1 Dev Studio against a 7.6.04 server out of the equation.

 

Only created the ticket with Support about 3 hours ago.  I haven’t heard back from them yet.  I will keep folks posted with what I learn.

 

Thanks

Dave

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Joe D'Souza
Sent: Wednesday, May 15, 2013 2:33 PM


To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

I thought you might have exhausted all possibilities.

 

This must be some sort of a bug then. I wish I had a 8.x system to try it out on but I do not. Keep us updated on what you find out.

 

What does BMC Support have to say about it?

 

Joe

 


From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Shellman, David
Sent: Wednesday, May 15, 2013 2:19 PM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

Joe,

 

Doesn’t matter if it’s a form that was created in Base Mode and upgraded to Custom or a form created in Best Practice Mode.  There is not an option to move an Attachment field to a Tab.

 

I’ve been creating simple forms in various modes to test various combinations.

 

Dave

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Joe D'Souza
Sent: Wednesday, May 15, 2013 2:15 PM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

I must have missed that somewhere that it’s a custom form.

 

Even if it is a custom form or object, (non OOTB), but if it was accidentally created from the base mode, it cannot be modified from the Best Practice mode, without creating an overlay.

 

So if you or some other developer did use the base mode at some point, to create either that panel or the attachment field in a base mode, you will experience what you are right now.

 

Joe

 


From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Shellman, David
Sent: Wednesday, May 15, 2013 2:11 PM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

Correct this is custom forms and workflow.

 

I understand the functionality of Overlays when using OOTB code and forms.

 

Dave

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Longwing, Lj
Sent: Wednesday, May 15, 2013 2:08 PM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

Joe,

Dave can answer definitively on this, but I got the impression that he is dealing with non OOTB code...which in that case, should be custom, not base with an overlay...but I may be mistaken

 

On Wed, May 15, 2013 at 11:55 AM, Joe D'Souza <jdsouza@shyle.net> wrote:

**

Overlays was one of the first thing I wanted to ask when I read your original email but thought I’d wade through the list in case someone already pointed that out..

 

You mentioned you want to stay away from overlays. Any specific reasons why?

 

Personally I feel it’s a great tool, and not using it might eventually get you to a spot where it might be very hard for you to reconcile your system to a state where they are actually useful,  in case you’ll eventually do decide to use overlays.

 

I see only pros to leveraging the use of overlays, the only con being they can be a pain in the rear sometimes (especially with the 7.6.04 version) with some of the ‘extra’ steps you need to do in order to even implement a small change. But those steps are worth the few extra seconds / minutes you spend on them I think.

 

Joe

 


From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Shellman, David
Sent: Wednesday, May 15, 2013 1:41 PM


To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

Dale,

 

LJ also noted he reproduced the issue with 8.1 Dev Studio against an 8.1 server.

 

Dave

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Dale Jones
Sent: Wednesday, May 15, 2013 1:00 PM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

David,

Did you create an overlay for view, each Attachment field , Attachment Pool, the destination Page and Tab?

May want to try in Base Mode.

May want to try in a Dev Studio version with the same version as Server.  (Rule of thumb is newer versions of Dev Studio will try to introduce features that Older Version of ARS server will not be aware of and not know how to handle.)

Take Care

 

Dale Jones

DCS

Raleigh, NC

919-523-6034


From: Action Request System discussion list(ARSList) [arslist@ARSLIST.ORG] on behalf of Shellman, David [dave.shellman@TE.COM]
Sent: Wednesday, May 15, 2013 12:39 PM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

**

Tried that.  You get a message that the form types do not match.

 

Dave


On May 15, 2013, at 12:24 PM, "Julie Sellers" <julsellers@YAHOO.COM> wrote:

**

Dave,
When you export a form it creates two items for import, the base form and the overlay (indicated by the form name with a '.o' extension).
Could you not export the data, export the form, and then only import the base form (basically deleting the overlay)?

Just a thought...

 

 


From: "Shellman, David" <dave.shellman@TE.COM>
To: arslist@ARSLIST.ORG
Sent: Wednesday, May 15, 2013 10:57 AM
Subject: Re: Question concerning Attachment Pool field

 

**

Mark,

 

If someone could verify it’s a version issue or if it’s an issue that also exists with 7.6.04 that would be great.

 

We went through several discussions with Jason Miller before we upgraded.  He was assured by Dev Studio developers that using a newer version is backward compatible.

 

We needed to upgrade to 8.1 to get us out of a corner that we had been painted into with 7.6.04 Dev Studio.  7.6.04 had several shortcomings once an “unmodified” form had an overlay added.  Since the forms were home grown from previous versions of the AR System we decided to go to convert them to “custom” forms.  7.6.04 Dev Studio does not have the ability to delete an Overlay which needs to be done before converting.

 

 

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Brittain, Mark
Sent: Wednesday, May 15, 2013 10:19 AM
To: arslist@ARSLIST.ORG
Subject: Re: Question concerning Attachment Pool field

 

**

Hi Dave,

 

The general rule has always been to use the same version of the admin/developer tool as the server version.  So there might be something with the 8.1 developer that is not compatible.

 

Mark

 

From: Action Request System discussion list(ARSList) [mailto:arslist@ARSLIST.ORG] On Behalf Of Shellman, David
Sent: Wednesday, May 15, 2013 9:51 AM
To: arslist@ARSLIST.ORG
Subject: Question concerning Attachment Pool field

 

**

I’m seeing something odd with Developer Studio.  Not sure it’s me or something with Dev Studio.

 

Using 8.1 Dev Studio against a 7.6.04 server (Windows app server running on Oracle).

 

 

We have a form that has two Attachment Pool fields on the form.  I’m attempting to move the fields to a Tab on a page field.  Drag and Drop doesn’t seem to allow me to move the fields there.  On a regular field, I can right mouse click and use the Move field option.  However with an Attachment field, I don’t see that option.

 

I can create a new Attachment pool field on the tab but I can’t seem to move an exist one.

 

Am I missing something obvious?

 

Dave

 

 

Dave Shellman
+1 717 810 3687 tel
+1 717 810 2124 fax
dave.shellman@te.com

 

 

MS 161-043
PO Box 3608
Harrisburg, PA 17105-3608

 

_ARSlist: "Where the Answers Are" and have been for 20 years_

 


This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

 

_ARSlist: "Where the Answers Are" and have been for 20 years_ _ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_

 

 

_ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_

 

_ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_ _ARSlist: "Where the Answers Are" and have been for 20 years_

**

_ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_ _ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_