[Date Prev] [Date Next] [Prev in Thread] [Next in Thread] [Date Index] [Thread Index]

Run API from filter deadlocks


I'm trying to run an API program I wrote in a filter Set Fields using $PROCESS$, but it's deadlocking and I can't see why.

The first thing I tried, described in the documentation here, is to increase the Max Thread counts of the relevant queues but no joy. I even tried directing the API to use a private queue (RPC 390680), but still it deadlocks.

I can see the deadlocking occur in a filter log: I first see my workflow (running in a fast queue) perform the $PROCESS$. It hangs for the configured 5 second timeout, then issues its error and completes its transaction. But it DID spin up my program, which (after my initial transaction fails and completes) then makes its connection (to private queue 390680) and correctly does its thing.

I haven't bothered to instrument the API program to test this, but I'm quite sure that it's hanging at the point that it tries to make the ARS connection.

FYI I need to use $PROCESS$ because I need the results of the API to be available to subsequent filter workflow. Run Process, which will run the API asynchronously, is not suitable.

Also FYI, it's a fully licensed development system with absolutely nothing else going on (no other person or processes are using it).

I've done this kind of thing before, but it's been a long time and my best recollection is that increasing the thread count solved the problem.

Any suggestions?

_ARSlist: "Where the Answers Are" and have been for 20 years_