[Date Prev] [Date Next] [Prev in Thread] [Next in Thread] [Date Index] [Thread Index]

Re: Remedy Run Process Issue



**
Hi Fred & LongWing,

I tried those changes. Also tried with the full path which does not help.

One quick query the restful-api-plugin does it work only for Remedy 9.1 and above. The reason I am asking is we have a Old version of Remedy which is 7.6.04.

Kindly check and let me know.

Thank you,
Sriram.



On Tue, Apr 18, 2017 at 8:38 PM, LJ LongWing <lj.longwing@gmail.com> wrote:
**
Sriram,
I'm going to 'redirect' you a bit, but doing things such as this via run-process are going to be extremely problem fraught....so I cannot recommend you move forward with doing things the way you are currently thinking about doing it....with that said, I can recommend you go with http://remedylegacy.com/tools/restful-api-plugin/, it works well and is allot more scalable than doing things via run-process....

Now...to answer your question....one of the problems that I see you might be having is that your path to java contains a space, but you aren't quoting it...so that could be causing you issues...so

@@:"C:\Program Files\Java\jdk1.8.0_121\jre\bin\java.exe" SampleClientPost1 "{\"short_description\":\"This is a test ticket\",\"assignment_group\":\"ENVIRONMENTS\",\"category\":\"Software\"}"

might work better for you if you insist on going down this road :)

On Tue, Apr 18, 2017 at 8:56 AM, sriram pm <ramjavaster@gmail.com> wrote:
**
Hi Experts,

I need your help.

I am executing an Run Process in an active link as shown below.

@@: C:\Program Files\Java\jdk1.8.0_121\jre\bin\java  SampleClientPost1  "{\"short_description\":\"This is a test ticket\",\"assignment_group\":\"ENVIRONMENTS\",\"category\":\"Software\"}"

The Logs says it is Successful as shown below:

<ACTL>             Run Process on server
<ACTL>               Server: ars-dev.tycoelectronics.com
<ACTL>               Process: C:\Program Files\Java\jdk1.8.0_121\jre\bin\java  SampleClientPost1  "{\"short_description\":\"This is a test ticket\",\"assignment_group\":\"ENVIRONMENTS\",\"category\":\"Software\"}"
<ACTL>                  Success

The above program is supposed to create a ticket in another cloud based ticketing tool. But even though it says successful the ticket is not getting created.

How to debug whether the program got executed or not?

When I run using Command Line it works fine.

Kindly check and advice.

Thank you,
Sriram.


_ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_

_ARSlist: "Where the Answers Are" and have been for 20 years_